Bombazo: WordPress actualizará automáticamente versiones inseguras

Según el equipo de WordPress la propuesta que habían hecho reciente miembros del equipo para actualizar automáticamente (de forma forzada) a sitios por debajo de la versión 4.7.x si se llevará acabo.

wordpress

¿Qué es lo que ocurrirá?

Bueno para abreviar: cualquier sitio que funcione con WordPress y use una versión de este que se encuentre por debajo de la versión 4.7.x recibirá una actualización forzada para que WordPress se atualice.

¿Qué implica?

Lo que implica es muy extenso, lo importante es para aquellos que les afectará de forma negativa: Esos sitio podrían dejar de funcionar.

En mi experiencia del día a día es que existen multitud de personas que piden que les hagan un sitio web, el desarrollador usa WordPress y el dueño del sitio ni enterado de que usa WordPress ni qué es este bicho.

Para casos como estos lo que puede pasar es que dentro de WordPress el usuario administrativo tenga asociado un correo electrónico que ya nadie usa ni lee y los avisos no llegarán. De modo que un día el dueño de equis sitio web se encontrará con que su página no funciona más.

Lo lógico que ocurra, como me pasa día a día, es que llaman al proveedor de hosting. Pero el proveedor de hosting poco podrá hacer debido a que él no es quien administra el sitio. A menos que se esté pagando un servicio de actualización o desarrollo web, el proveedor de hosting no corregirá ese sitio web.

¿Entonces qué se puede hacer?

Lo ideal es siempre tener actualizados los datos de acceso de FTP, panel de hosting, de la administración de dominio, de los correos que existan y en general cualquier acceso que corresponda al servicio web.

“Pues no tengo ninguno de estos accesos”: Pide entonces a tu desarrollador web (el que hizo tu sitio) que te diga si lo hizo en WordPress o en qué. Que te brinde accesos y pide a tu proveedor de hosting y de dominios que te brinde tus accesos.

Si llegas a encontrar que tu sitio está hecho en WordPress verifica si está actualizado y sino date a la tarea de ver que se actualice, haciendo claro un respaldo antes por precaución.

¿Averiguaste que tienes un sitio con WordPress anterior a la 4.7.x y no quieres que se actualice automáticamente?

Puedes salvarte de esto y actualizar a tu ritmo y deseo si sigues los pasos del siguiente enlace en el que se indica cómo evitar las actualizaciones automáticas: https://codex.wordpress.org/es:Configurando_actualizaciones_automaticas

La comunidad de WordPress ha decidido esto para tener una Internet más segura. Recordar que los sitios no actualizados tienen vulnerabilidades y que estas vulnerabilidades son explotadas por “hackers” y que como mínimo borrarán la información o hasta la cambiarán por otra.

Como decía antes, muchos no saben ni sobre qué está trabajando su sitio web. Hay sitios muy viejos y que casi que por gracia de Dios siguen funcionando. Si se hace esta actualización muchos de ellos morirán por fin. Tal vez la mayoría sean sitios que nadie visita y que nadie usa, con lo que pasaría desapercibido todo este cambio. Puede ser que al contrario, que cause un alboroto y todo mundo empiece a dar gritos y pataleos porque sus sitios no están en línea. Ya veremos qué ocurre.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *